aboutsummaryrefslogtreecommitdiffstats
path: root/build/external/deb/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'build/external/deb/debian/rules')
-rwxr-xr-xbuild/external/deb/debian/rules6
1 files changed, 6 insertions, 0 deletions
diff --git a/build/external/deb/debian/rules b/build/external/deb/debian/rules
index 2b1157e5e48..901d4689766 100755
--- a/build/external/deb/debian/rules
+++ b/build/external/deb/debian/rules
@@ -1,6 +1,9 @@
#!/usr/bin/make -f
DH_VERBOSE = 1
DEB_BUILD_OPTIONS = noddebs
+DEB_CFLAGS_MAINT_STRIP = -flto=auto -ffat-lto-objects -flto=auto -ffat-lto-objects -O2
+DEB_LDFLAGS_MAINT_STRIP = -flto=auto -ffat-lto-objects -flto=auto -ffat-lto-objects
+DEB_CFLAGS_MAINT_APPEND = -O3
PKG=vpp-ext-deps
VERSION = $(shell dpkg-parsechangelog | sed -nr '/^Version:/s/Version: //p')
@@ -23,5 +26,8 @@ override_dh_auto_configure:
override_dh_install:
make $(MAKE_ARGS) install
+ @mkdir -p $(INSTALL_DIR)
dh_install -p$(PKG) --autodest /opt
+override_dh_shlibdeps:
+ dh_shlibdeps -l$(INSTALL_DIR)lib/