aboutsummaryrefslogtreecommitdiffstats
path: root/build/external/deb/debian
diff options
context:
space:
mode:
Diffstat (limited to 'build/external/deb/debian')
-rwxr-xr-xbuild/external/deb/debian/compat1
-rw-r--r--build/external/deb/debian/control13
-rw-r--r--build/external/deb/debian/dkms/Makefile10
-rwxr-xr-xbuild/external/deb/debian/rules27
4 files changed, 51 insertions, 0 deletions
diff --git a/build/external/deb/debian/compat b/build/external/deb/debian/compat
new file mode 100755
index 00000000000..ec635144f60
--- /dev/null
+++ b/build/external/deb/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/build/external/deb/debian/control b/build/external/deb/debian/control
new file mode 100644
index 00000000000..80b81b8b375
--- /dev/null
+++ b/build/external/deb/debian/control
@@ -0,0 +1,13 @@
+Source: vpp-ext-deps
+Section: net
+Priority: extra
+Maintainer: vpp-dev@lists.fd.io
+Build-Depends: debhelper (>= 9), dkms
+Standards-Version: 3.9.4
+
+Package: vpp-ext-deps
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: VPP developer package containing dependencies
+Replaces: vpp-dpdk-dev
+Conflicts: vpp-dpdk-dev
diff --git a/build/external/deb/debian/dkms/Makefile b/build/external/deb/debian/dkms/Makefile
new file mode 100644
index 00000000000..452c7c265e9
--- /dev/null
+++ b/build/external/deb/debian/dkms/Makefile
@@ -0,0 +1,10 @@
+obj-m:=igb_uio.o
+
+CONFIG_MODULE_SIG=n
+
+EXTRA_CFLAGS += -Winline -I$(PWD)
+
+default:
+ $(MAKE) -C /lib/modules/$(shell uname -r)/build M=$(shell pwd) modules
+clean:
+ $(MAKE) -C /lib/modules/$(shell uname -r)/build M=$(shell pwd) clean
diff --git a/build/external/deb/debian/rules b/build/external/deb/debian/rules
new file mode 100755
index 00000000000..6ffefc1d0b2
--- /dev/null
+++ b/build/external/deb/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+DH_VERBOSE = 1
+PKG=vpp-ext-deps
+
+VERSION = $(shell dpkg-parsechangelog | sed -nr '/^Version:/s/Version: //p')
+BASE_VER = $(word 1, $(subst -, ,$(VERSION)))
+
+export DPDK_BUILD_DIR=$(CURDIR)/_build
+export DPDK_INSTALL_DIR=$(CURDIR)/debian/tmp/opt/vpp/external/$(shell uname -m)/
+
+MAKE_ARGS=-C ..
+
+include /usr/share/dpkg/default.mk
+
+%:
+ dh $@
+
+override_dh_clean:
+ make $(MAKE_ARGS) clean
+
+override_dh_auto_configure:
+ make $(MAKE_ARGS) config
+
+override_dh_install:
+ make $(MAKE_ARGS) install
+ dh_install -p$(PKG) --autodest /opt
+