aboutsummaryrefslogtreecommitdiffstats
path: root/build/external/packages/rdma-core.mk
diff options
context:
space:
mode:
Diffstat (limited to 'build/external/packages/rdma-core.mk')
-rw-r--r--build/external/packages/rdma-core.mk35
1 files changed, 17 insertions, 18 deletions
diff --git a/build/external/packages/rdma-core.mk b/build/external/packages/rdma-core.mk
index b8092e4cb4d..f015322775f 100644
--- a/build/external/packages/rdma-core.mk
+++ b/build/external/packages/rdma-core.mk
@@ -13,10 +13,20 @@
RDMA_CORE_DEBUG?=n
-rdma-core_version := 35.0
+# NOTE: When updating the rdma-core version in conjunction with an update of the
+# dpdk version, please update ../mlx_rdma_dpdk_matrix.txt to include the
+# updated version matrix with the dpdk and rdma-core version.
+#
+# Also, please verify that the DPDK RDMA driver is built into the dpdk plugin
+# as follows:
+# 1. from workspace root directory, 'make -C build/external build-deb'
+# 2. Verify that the file build/external/dpdk_mlx_default.sh was generated
+# and contains 'DPDK_MLX_DEFAULT=y'
+#
+rdma-core_version := 51.0
rdma-core_tarball := rdma-core-$(rdma-core_version).tar.gz
-rdma-core_tarball_md5sum_31.1 := f14b3eba775c2eba0d9433bfb3bae637
-rdma-core_tarball_md5sum_35.0 := 85afb89ec536ef229c0fef6cb87e8665
+rdma-core_tarball_md5sum_49.0 := 9fe3909f19c7e0276c9e546411bbb49c
+rdma-core_tarball_md5sum_51.0 := ed95d79f782ea00bd7233d453abd60b3
rdma-core_tarball_md5sum := $(rdma-core_tarball_md5sum_$(rdma-core_version))
rdma-core_tarball_strip_dirs := 1
rdma-core_url := http://github.com/linux-rdma/rdma-core/releases/download/v$(rdma-core_version)/$(rdma-core_tarball)
@@ -32,27 +42,16 @@ define rdma-core_config_cmds
-DENABLE_STATIC=1 -DENABLE_RESOLVE_NEIGH=0 -DNO_PYVERBS=1 -DENABLE_VALGRIND=0\
-DCMAKE_BUILD_TYPE=$(RDMA_BUILD_TYPE) -DCMAKE_INSTALL_PREFIX=$(rdma-core_install_dir) \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_C_FLAGS='-fPIC -fvisibility=hidden' > $(rdma-core_config_log)
+ -DCMAKE_INSTALL_RUNDIR:PATH=/run \
+ -DCMAKE_C_FLAGS='-fPIC' -DNO_MAN_PAGES=ON | tee $(rdma-core_config_log)
endef
define rdma-core_build_cmds
- $(CMAKE) --build $(rdma-core_build_dir) -- libccan.a libibverbs.a librdma_util.a libmlx5.a libmlx4.a > $(rdma-core_build_log)
- sed 's/^Libs.private:.*/Libs.private: -lmlx4 -lmlx5 -libverbs -lrdma_util -lccan -lpthread/' -i $(rdma-core_build_dir)/lib/pkgconfig/libibverbs.pc >> $(rdma-core_build_log)
+ $(CMAKE) --build $(rdma-core_build_dir) | tee $(rdma-core_build_log)
endef
define rdma-core_install_cmds
- mkdir -p $(rdma-core_install_dir)/lib/pkgconfig
- cp -av $(rdma-core_build_dir)/include $(rdma-core_install_dir) > $(rdma-core_install_log)
- cp -v $(rdma-core_build_dir)/lib/pkgconfig/libibverbs.pc \
- $(rdma-core_build_dir)/lib/pkgconfig/libmlx5.pc \
- $(rdma-core_build_dir)/lib/pkgconfig/libmlx4.pc \
- $(rdma-core_install_dir)/lib/pkgconfig >> $(rdma-core_install_log)
- cp -v $(rdma-core_build_dir)/lib/statics/libibverbs.a \
- $(rdma-core_build_dir)/lib/statics/libmlx5.a \
- $(rdma-core_build_dir)/lib/statics/libmlx4.a \
- $(rdma-core_build_dir)/util/librdma_util.a \
- $(rdma-core_build_dir)/ccan/libccan.a \
- $(rdma-core_install_dir)/lib >> $(rdma-core_install_log)
+ $(CMAKE) --install $(rdma-core_build_dir) | tee $(rdma-core_install_log)
endef
$(eval $(call package,rdma-core))