aboutsummaryrefslogtreecommitdiffstats
path: root/build/external/packages/rdma-core.mk
diff options
context:
space:
mode:
Diffstat (limited to 'build/external/packages/rdma-core.mk')
-rw-r--r--build/external/packages/rdma-core.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/build/external/packages/rdma-core.mk b/build/external/packages/rdma-core.mk
index 0e8c878034e..d3363e141bc 100644
--- a/build/external/packages/rdma-core.mk
+++ b/build/external/packages/rdma-core.mk
@@ -28,14 +28,14 @@ RDMA_FILES := include/infiniband/verbs.h \
define rdma-core_config_cmds
cd $(rdma-core_build_dir) && \
- cmake -G Ninja $(rdma-core_src_dir) \
+ $(CMAKE) -G Ninja $(rdma-core_src_dir) \
-DENABLE_STATIC=1 -DENABLE_RESOLVE_NEIGH=0 -DNO_PYVERBS=1 -DENABLE_VALGRIND=0 \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_C_FLAGS=-fPIC > $(rdma-core_config_log)
endef
define rdma-core_build_cmds
- cmake --build $(rdma-core_build_dir) -- libibverbs.a libmlx5.a > $(rdma-core_build_log)
+ $(CMAKE) --build $(rdma-core_build_dir) -- libibverbs.a libmlx5.a > $(rdma-core_build_log)
endef
define rdma-core_install_cmds