aboutsummaryrefslogtreecommitdiffstats
path: root/build/external/packages/rdma-core.mk
diff options
context:
space:
mode:
Diffstat (limited to 'build/external/packages/rdma-core.mk')
-rw-r--r--build/external/packages/rdma-core.mk46
1 files changed, 46 insertions, 0 deletions
diff --git a/build/external/packages/rdma-core.mk b/build/external/packages/rdma-core.mk
new file mode 100644
index 00000000000..0e8c878034e
--- /dev/null
+++ b/build/external/packages/rdma-core.mk
@@ -0,0 +1,46 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+rdma-core_version := 23
+rdma-core_tarball := rdma-core-$(rdma-core_version).tar.gz
+rdma-core_tarball_md5sum_22.1 := dde4d30e3db20893408ae51041117034
+rdma-core_tarball_md5sum_23 := c78575735c4a71609c1a214ea16cd8dc
+rdma-core_tarball_md5sum := $(rdma-core_tarball_md5sum_$(rdma-core_version))
+rdma-core_tarball_strip_dirs := 1
+rdma-core_url := http://github.com/linux-rdma/rdma-core/releases/download/v$(rdma-core_version)/$(rdma-core_tarball)
+
+RDMA_FILES := include/infiniband/verbs.h \
+ include/infiniband/verbs_api.h \
+ include/infiniband/ib_user_ioctl_verbs.h \
+ include/rdma/ib_user_verbs.h \
+ lib/statics/libibverbs.a \
+ lib/statics/libmlx5.a
+
+define rdma-core_config_cmds
+ cd $(rdma-core_build_dir) && \
+ cmake -G Ninja $(rdma-core_src_dir) \
+ -DENABLE_STATIC=1 -DENABLE_RESOLVE_NEIGH=0 -DNO_PYVERBS=1 -DENABLE_VALGRIND=0 \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_C_FLAGS=-fPIC > $(rdma-core_config_log)
+endef
+
+define rdma-core_build_cmds
+ cmake --build $(rdma-core_build_dir) -- libibverbs.a libmlx5.a > $(rdma-core_build_log)
+endef
+
+define rdma-core_install_cmds
+ mkdir -p $(rdma-core_install_dir)
+ tar -C $(rdma-core_build_dir) --xform='s|/statics/|/|' -hc $(RDMA_FILES) | tar -C $(rdma-core_install_dir) -xv > $(rdma-core_install_log)
+endef
+
+$(eval $(call package,rdma-core))