aboutsummaryrefslogtreecommitdiffstats
path: root/build/optional/deb/debian
diff options
context:
space:
mode:
Diffstat (limited to 'build/optional/deb/debian')
-rwxr-xr-xbuild/optional/deb/debian/compat1
-rw-r--r--build/optional/deb/debian/control11
-rwxr-xr-xbuild/optional/deb/debian/rules33
3 files changed, 45 insertions, 0 deletions
diff --git a/build/optional/deb/debian/compat b/build/optional/deb/debian/compat
new file mode 100755
index 00000000000..f599e28b8ab
--- /dev/null
+++ b/build/optional/deb/debian/compat
@@ -0,0 +1 @@
+10
diff --git a/build/optional/deb/debian/control b/build/optional/deb/debian/control
new file mode 100644
index 00000000000..d892395ddab
--- /dev/null
+++ b/build/optional/deb/debian/control
@@ -0,0 +1,11 @@
+Source: vpp-opt-deps
+Section: net
+Priority: extra
+Maintainer: vpp-dev@lists.fd.io
+Build-Depends: debhelper (>= 9), dkms
+Standards-Version: 3.9.4
+
+Package: vpp-opt-deps
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: VPP developer package containing optional dependencies
diff --git a/build/optional/deb/debian/rules b/build/optional/deb/debian/rules
new file mode 100755
index 00000000000..2fd8b3d110d
--- /dev/null
+++ b/build/optional/deb/debian/rules
@@ -0,0 +1,33 @@
+#!/usr/bin/make -f
+DH_VERBOSE = 1
+DEB_BUILD_OPTIONS = noddebs
+DEB_CFLAGS_MAINT_STRIP = -flto=auto -ffat-lto-objects -flto=auto -ffat-lto-objects -O2
+DEB_LDFLAGS_MAINT_STRIP = -flto=auto -ffat-lto-objects -flto=auto -ffat-lto-objects
+DEB_CFLAGS_MAINT_APPEND = -O3
+PKG=vpp-opt-deps
+
+VERSION = $(shell dpkg-parsechangelog | sed -nr '/^Version:/s/Version: //p')
+BASE_VER = $(word 1, $(subst -, ,$(VERSION)))
+
+export BUILD_DIR=$(CURDIR)/_build
+export INSTALL_DIR=$(CURDIR)/debian/tmp/opt/vpp/optional/$(shell uname -m)/
+
+MAKE_ARGS=-C ..
+
+include /usr/share/dpkg/default.mk
+
+%:
+ dh $@
+
+override_dh_clean:
+ make $(MAKE_ARGS) clean
+
+override_dh_auto_configure:
+
+override_dh_install:
+ make $(MAKE_ARGS) install
+ @mkdir -p $(INSTALL_DIR)
+ dh_install -p$(PKG) --autodest /opt
+
+override_dh_shlibdeps:
+ dh_shlibdeps -l$(INSTALL_DIR)lib/:$(INSTALL_DIR)lib64