aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/sixrd-plugin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/sixrd-plugin/Makefile.am')
-rw-r--r--plugins/sixrd-plugin/Makefile.am38
1 files changed, 0 insertions, 38 deletions
diff --git a/plugins/sixrd-plugin/Makefile.am b/plugins/sixrd-plugin/Makefile.am
deleted file mode 100644
index eb0d806aa6a..00000000000
--- a/plugins/sixrd-plugin/Makefile.am
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright (c) 2015 Cisco and/or its affiliates.
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at:
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-AUTOMAKE_OPTIONS = foreign subdir-objects
-
-AM_CFLAGS = -Wall
-AM_LDFLAGS = -module -shared -avoid-version
-
-libsixrd_plugin_la_SOURCES = \
- sixrd/sixrd.c \
- sixrd/sixrd_dpo.c \
- sixrd/ip4_sixrd.c \
- sixrd/ip6_sixrd.c
-
-noinst_HEADERS = \
- sixrd/sixrd.h \
- sixrd/sixrd_dpo.h
-
-BUILT_SOURCES =
-
-vpppluginsdir = ${libdir}/vpp_plugins
-
-vppplugins_LTLIBRARIES = libsixrd_plugin.la
-
-
-# Remove *.la files
-install-data-hook:
- @(cd $(vpppluginsdir) && $(RM) $(vppplugins_LTLIBRARIES))