aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 05457ebe40c..f6bad2ce133 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -87,7 +87,16 @@ foreach(DIR ${SUBDIRS})
add_subdirectory(${DIR})
endforeach()
+##############################################################################
+# packaging
+##############################################################################
include(cmake/pack.cmake)
+add_vpp_packaging(
+ NAME "vpp"
+ VENDOR "fd.io"
+ DESCRIPTION "Vector Packet Processor"
+)
+
##############################################################################
# detect if we are inside git repo and add configure dependency
##############################################################################