aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am99
1 files changed, 0 insertions, 99 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index f5fa3398ea4..00000000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright (c) 2016 Cisco and/or its affiliates.
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at:
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-###############################################################################
-# Global Defines
-###############################################################################
-
-AUTOMAKE_OPTIONS = foreign subdir-objects
-ACLOCAL_AMFLAGS = -I m4
-AM_LIBTOOLFLAGS = --quiet
-
-AM_CFLAGS = @CPU_FLAGS@ -Wall
-AM_CXXFLAGS = -Wall -std=gnu++11
-
-SUBDIRS = .
-SUFFIXES = .api.h .api .api.json
-API_FILES =
-noinst_HEADERS =
-dist_bin_SCRIPTS =
-lib_LTLIBRARIES =
-BUILT_SOURCES =
-CLEANFILES =
-install-data-local:
- @echo "Building vppctl command list..."
- @DIR_SEARCH="$(srcdir)" ; \
- DIR_EXCLUDE="examples" ; \
- GREP_TIME=`time (grep -wIr "\.path = " $$DIR_SEARCH --exclude-dir=$$DIR_EXCLUDE \
- | cut -d '"' -f2 | sort -u > $(srcdir)/scripts/vppctl-cmd-list) 2>&1` ; \
- GREP_TIME=`echo $$GREP_TIME | awk '{print $$2}'` ; \
- echo "Command list built, Time taken: $$GREP_TIME"
-
-###############################################################################
-# Components
-###############################################################################
-
-include vppinfra.am
-include vppapigen.am
-
-if ENABLE_PERFTOOL
-include perftool.am
-endif
-
-if ENABLE_G2
-include g2.am
-endif
-
-if ENABLE_SVM
-include svm.am
-endif
-
-if ENABLE_VLIB
-include vlib.am
-endif
-
-if ENABLE_SVM
-if ENABLE_VLIB
-include vlib-api.am
-include vnet.am
-include vpp.am
-include vpp-api-test.am
-include vcl.am
-
-SUBDIRS += plugins
-SUBDIRS += vpp-api/vapi
-
-if ENABLE_PAPI
-include vpp-api.am
-SUBDIRS += vpp-api/python
-endif
-
-###############################################################################
-# API
-###############################################################################
-
-include suffix-rules.mk
-
-# Set the suffix list
-apidir = $(prefix)/share/vpp/api/core
-
-api_DATA = \
- $(patsubst %.api,%.api.json,$(API_FILES))
-
-BUILT_SOURCES += \
- $(patsubst %.api,%.api.h,$(API_FILES))
-
-endif # if ENABLE_VLIB
-endif # if ENABLE_SVM
-
-CLEANFILES += $(BUILT_SOURCES) $(api_DATA)