aboutsummaryrefslogtreecommitdiffstats
path: root/src/cmake/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/cmake/CMakeLists.txt')
-rw-r--r--src/cmake/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/cmake/CMakeLists.txt b/src/cmake/CMakeLists.txt
new file mode 100644
index 00000000000..7eb1790f2e8
--- /dev/null
+++ b/src/cmake/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+install(
+ FILES
+ api.cmake
+ cpu.cmake
+ library.cmake
+ plugin.cmake
+ VPPConfig.cmake
+
+ DESTINATION
+ lib/cmake/vpp
+
+ COMPONENT vpp-dev
+)