aboutsummaryrefslogtreecommitdiffstats
path: root/src/pkg/debian/rules.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/pkg/debian/rules.in')
-rw-r--r--[-rwxr-xr-x]src/pkg/debian/rules.in9
1 files changed, 1 insertions, 8 deletions
diff --git a/src/pkg/debian/rules.in b/src/pkg/debian/rules.in
index 15f8eb6f810..1958497f5ed 100755..100644
--- a/src/pkg/debian/rules.in
+++ b/src/pkg/debian/rules.in
@@ -23,8 +23,6 @@ build3vers := $(shell py3versions -sv)
override_dh_strip:
dh_strip --dbg-package=vpp-dbg
-DEB_HOST_MULTIARCH = $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
-
override_dh_install:
@for c in @VPP_COMPONENTS@; do \
@CMAKE_COMMAND@ \
@@ -33,12 +31,7 @@ override_dh_install:
-D CMAKE_INSTALL_PREFIX=@VPP_BINARY_DIR@/debian/$$c \
-P @CMAKE_BINARY_DIR@/cmake_install.cmake 2>&1 \
| grep -v 'Set runtime path of' ; \
- if [ -d debian/$$c/lib ] ; then \
- mv debian/$$c/lib debian/$$c/$(DEB_HOST_MULTIARCH) ; \
- mkdir -p debian/$$c/usr/lib ; \
- mv debian/$$c/$(DEB_HOST_MULTIARCH) debian/$$c/usr/lib ; \
- fi ; \
- for d in bin include share ; do \
+ for d in bin include share lib ; do \
if [ -d debian/$$c/$$d ] ; then \
mkdir -p debian/$$c/usr ; \
mv debian/$$c/$$d debian/$$c/usr/$$d ; \