aboutsummaryrefslogtreecommitdiffstats
path: root/src/pkg/debian/rules.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/pkg/debian/rules.in')
-rwxr-xr-xsrc/pkg/debian/rules.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/pkg/debian/rules.in b/src/pkg/debian/rules.in
index 0351ee503e6..ceef46a297a 100755
--- a/src/pkg/debian/rules.in
+++ b/src/pkg/debian/rules.in
@@ -7,15 +7,20 @@ DH_VERBOSE = 1
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/default.mk
-export PYBUILD_NAME = vpp-api-python
+export PYBUILD_NAME = vpp-api
export PYBUILD_DIR = @CMAKE_SOURCE_DIR@/vpp-api/python
export PYBUILD_DESTDIR_python2=debian/vpp-api-python/
export PYBUILD_DISABLE_python2=test
+export PYBUILD_DESTDIR_python3=debian/python3-vpp-api/
+export PYBUILD_DISABLE_python3=test
export PYBUILD_SYSTEM=distutils
+buildvers := $(shell pyversions -sv)
+build3vers := $(shell py3versions -sv)
+
# main packaging script based on dh7 syntax
%:
- dh $@ --with systemd,python2 --buildsystem=pybuild
+ dh $@ --with systemd,python2,python3 --buildsystem=pybuild
override_dh_strip:
dh_strip --dbg-package=vpp-dbg