aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/acl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/acl/CMakeLists.txt')
-rw-r--r--src/plugins/acl/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/plugins/acl/CMakeLists.txt b/src/plugins/acl/CMakeLists.txt
index 2040522affd..1779c49966b 100644
--- a/src/plugins/acl/CMakeLists.txt
+++ b/src/plugins/acl/CMakeLists.txt
@@ -11,11 +11,14 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-add_vpp_plugin(acl_plugin
- acl.api
+add_vpp_plugin(acl
+ SOURCES
acl.c
hash_lookup.c
lookup_context.c
sess_mgmt_node.c
dataplane_node.c
+
+ API_FILES
+ acl.api
)