aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/dev_ena/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/dev_ena/CMakeLists.txt')
-rw-r--r--src/plugins/dev_ena/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/plugins/dev_ena/CMakeLists.txt b/src/plugins/dev_ena/CMakeLists.txt
new file mode 100644
index 00000000000..d9224d6fd9b
--- /dev/null
+++ b/src/plugins/dev_ena/CMakeLists.txt
@@ -0,0 +1,21 @@
+# SPDX-License-Identifier: Apache-2.0
+# Copyright(c) 2022 Cisco Systems, Inc.
+
+add_vpp_plugin(dev_ena
+ SOURCES
+ aq.c
+ aenq.c
+ ena.c
+ format.c
+ format_aq.c
+ port.c
+ queue.c
+ rx_node.c
+ tx_node.c
+ reg.c
+
+ MULTIARCH_SOURCES
+ rx_node.c
+ tx_node.c
+)
+