aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/gbp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/gbp/CMakeLists.txt')
-rw-r--r--src/plugins/gbp/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/plugins/gbp/CMakeLists.txt b/src/plugins/gbp/CMakeLists.txt
index a9e9bd62692..738154a16c7 100644
--- a/src/plugins/gbp/CMakeLists.txt
+++ b/src/plugins/gbp/CMakeLists.txt
@@ -11,8 +11,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-add_vpp_plugin(gbp_plugin
- gbp.api
+add_vpp_plugin(gbp
+ SOURCES
gbp_subnet.c
gbp_contract.c
gbp_endpoint.c
@@ -24,4 +24,7 @@ add_vpp_plugin(gbp_plugin
gbp_fwd.c
gbp_fwd_dpo.c
gbp_api.c
+
+ API_FILES
+ gbp.api
)