aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/http_static/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/http_static/CMakeLists.txt')
-rw-r--r--src/plugins/http_static/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/plugins/http_static/CMakeLists.txt b/src/plugins/http_static/CMakeLists.txt
new file mode 100644
index 00000000000..5e0344cd858
--- /dev/null
+++ b/src/plugins/http_static/CMakeLists.txt
@@ -0,0 +1,30 @@
+
+# Copyright (c) <current-year> <your-organization>
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(http_static
+ SOURCES
+ http_static.c
+ static_server.c
+ http_static.h
+
+ API_FILES
+ http_static.api
+
+ INSTALL_HEADERS
+ http_static_all_api_h.h
+ http_static_msg_enum.h
+
+ API_TEST_SOURCES
+ http_static_test.c
+)