aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/lacp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/lacp/CMakeLists.txt')
-rw-r--r--src/plugins/lacp/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/plugins/lacp/CMakeLists.txt b/src/plugins/lacp/CMakeLists.txt
new file mode 100644
index 00000000000..0bd79e9800a
--- /dev/null
+++ b/src/plugins/lacp/CMakeLists.txt
@@ -0,0 +1,32 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(lacp_plugin
+ lacp.api
+ lacp.c
+ lacp_api.c
+ selection.c
+ rx_machine.c
+ tx_machine.c
+ mux_machine.c
+ ptx_machine.c
+ cli.c
+ input.c
+ node.c
+)
+
+add_vpp_api_test_plugin(lacp_test_plugin
+ lacp.api
+ lacp_test.c
+)
+