aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/lisp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/lisp/CMakeLists.txt')
-rw-r--r--src/plugins/lisp/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/plugins/lisp/CMakeLists.txt b/src/plugins/lisp/CMakeLists.txt
index bf0d60aab0f..743a17e69c8 100644
--- a/src/plugins/lisp/CMakeLists.txt
+++ b/src/plugins/lisp/CMakeLists.txt
@@ -11,6 +11,11 @@
# See the License for the specific language governing permissions and
# limitations under the License.
+if(NOT OPENSSL_FOUND)
+ message(WARNING "OpenSSL not found - lisp plugin disabled")
+ return()
+endif()
+
##############################################################################
# LISP control plane: lisp-cp
##############################################################################