aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/nat/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/nat/CMakeLists.txt')
-rw-r--r--src/plugins/nat/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/plugins/nat/CMakeLists.txt b/src/plugins/nat/CMakeLists.txt
index 372bbd61bb3..edba893cafe 100644
--- a/src/plugins/nat/CMakeLists.txt
+++ b/src/plugins/nat/CMakeLists.txt
@@ -11,6 +11,21 @@
# See the License for the specific language governing permissions and
# limitations under the License.
+set(NAT_SRCS
+ lib/alloc.c
+)
+
+set(NAT_HEADERS
+ lib/alloc.h
+)
+
+add_vpp_library(nat
+ SOURCES ${NAT_SRCS}
+ LINK_LIBRARIES m
+ INSTALL_HEADERS ${NAT_HEADERS}
+ COMPONENT libnat
+)
+
add_vpp_plugin(nat
SOURCES
nat.c