aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/npt66/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/npt66/CMakeLists.txt')
-rw-r--r--src/plugins/npt66/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/plugins/npt66/CMakeLists.txt b/src/plugins/npt66/CMakeLists.txt
new file mode 100644
index 00000000000..aee784d96f0
--- /dev/null
+++ b/src/plugins/npt66/CMakeLists.txt
@@ -0,0 +1,17 @@
+# SPDX-License-Identifier: Apache-2.0
+# Copyright(c) 2023 Cisco Systems, Inc.
+
+add_vpp_plugin(npt66
+ SOURCES
+ npt66.c
+ npt66_api.c
+ npt66_cli.c
+ npt66_node.c
+
+
+ MULTIARCH_SOURCES
+ npt66_node.c
+
+ API_FILES
+ npt66.api
+)