aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/sflow/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/sflow/CMakeLists.txt')
-rw-r--r--src/plugins/sflow/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/plugins/sflow/CMakeLists.txt b/src/plugins/sflow/CMakeLists.txt
new file mode 100644
index 00000000000..fc20f0f78e8
--- /dev/null
+++ b/src/plugins/sflow/CMakeLists.txt
@@ -0,0 +1,42 @@
+
+# Copyright (c) 2024 InMon Corp.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+include_directories(${CMAKE_SOURCE_DIR}/vpp-api ${CMAKE_CURRENT_BINARY_DIR}/../../vpp-api)
+add_vpp_plugin(sflow
+ SOURCES
+ sflow.c
+ node.c
+ sflow_common.h
+ sflow.h
+ sflow_psample.c
+ sflow_psample.h
+ sflow_psample_fields.h
+ sflow_usersock.c
+ sflow_usersock.h
+ sflow_vapi.c
+ sflow_vapi.h
+
+ MULTIARCH_SOURCES
+ node.c
+
+ API_FILES
+ sflow.api
+
+ API_TEST_SOURCES
+ sflow_test.c
+
+ LINK_LIBRARIES
+ vppapiclient
+ vapiclient
+)