aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/tlsmbedtls/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/tlsmbedtls/CMakeLists.txt')
-rw-r--r--src/plugins/tlsmbedtls/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/plugins/tlsmbedtls/CMakeLists.txt b/src/plugins/tlsmbedtls/CMakeLists.txt
new file mode 100644
index 00000000000..af77c248cb3
--- /dev/null
+++ b/src/plugins/tlsmbedtls/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+message("-- Looking for mbedTLS")
+find_path(MBEDTLS_INCLUDE_DIR NAMES mbedtls/ssl.h)
+find_library(MBEDTLS_LIB1 NAMES mbedtls)
+find_library(MBEDTLS_LIB2 NAMES mbedx509)
+find_library(MBEDTLS_LIB3 NAMES mbedcrypto)
+
+set (MBEDTLS_LIB ${MBEDTLS_LIB1} ${MBEDTLS_LIB2} ${MBEDTLS_LIB3})
+
+if(MBEDTLS_INCLUDE_DIR AND MBEDTLS_LIB)
+ include_directories(${MBEDTLS_INCLUDE_DIR})
+ add_vpp_plugin(tlsmbedtls_plugin tls_mbedtls.c)
+ target_link_libraries(tlsmbedtls_plugin ${MBEDTLS_LIB})
+ message("-- Found mbedTLS: ${MBEDTLS_INCLUDE_DIR} ${MBEDTLS_LIB}")
+else()
+ message("-- mbedTLS not found - tlsmbedtls_plugin disabled")
+endif()
+