aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/tlspicotls/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/tlspicotls/CMakeLists.txt')
-rw-r--r--src/plugins/tlspicotls/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/plugins/tlspicotls/CMakeLists.txt b/src/plugins/tlspicotls/CMakeLists.txt
index f23ae6ccb8a..e60a0e0ebd4 100644
--- a/src/plugins/tlspicotls/CMakeLists.txt
+++ b/src/plugins/tlspicotls/CMakeLists.txt
@@ -1,11 +1,16 @@
include (CheckFunctionExists)
+if(NOT OPENSSL_FOUND)
+ message(WARNING "OpenSSL not found - tlspicotls plugin disabled")
+ return()
+endif()
+
# We should rely on a picotls specific version, but as
# we expect dependancies to be built with vpp-ext-deps
# it's reasonable to make this check to avoid breaking
# existing builds when upgrading the quicly/picotls
# versions
-set(EXPECTED_QUICLY_VERSION "0.1.3-vpp")
+set(EXPECTED_QUICLY_VERSION "0.1.4-vpp")
vpp_find_path(QUICLY_INCLUDE_DIR NAMES quicly.h)