aboutsummaryrefslogtreecommitdiffstats
path: root/src/vat/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/vat/CMakeLists.txt')
-rw-r--r--src/vat/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/vat/CMakeLists.txt b/src/vat/CMakeLists.txt
index ee53386f114..e5945b20dec 100644
--- a/src/vat/CMakeLists.txt
+++ b/src/vat/CMakeLists.txt
@@ -32,7 +32,6 @@ add_vpp_executable(vpp_api_test ENABLE_EXPORTS
ip_types_api.c
ip_types.c
protocols.def
- ../vnet/arp/arp_test.c
DEPENDS api_headers
@@ -42,7 +41,7 @@ add_vpp_executable(vpp_api_test ENABLE_EXPORTS
vatplugin
vppinfra
Threads::Threads
- rt m dl crypto
+ dl
)
##############################################################################
@@ -58,7 +57,7 @@ add_vpp_executable(vpp_json_test ENABLE_EXPORTS NO_INSTALL
##############################################################################
install(
FILES vat.h json_format.h
- DESTINATION include/vat
+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/vat
COMPONENT vpp-dev
)