aboutsummaryrefslogtreecommitdiffstats
path: root/src/vat/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/vat/CMakeLists.txt')
-rw-r--r--src/vat/CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/src/vat/CMakeLists.txt b/src/vat/CMakeLists.txt
index feb335c0679..bc26c3e5c23 100644
--- a/src/vat/CMakeLists.txt
+++ b/src/vat/CMakeLists.txt
@@ -22,7 +22,7 @@ add_vpp_library(vatplugin
##############################################################################
# vpp_api_test
##############################################################################
-add_vpp_executable(vpp_api_test ENABLE_EXPORTS
+add_vpp_executable(vpp_api_test ENABLE_EXPORTS NO_INSTALL
SOURCES
api_format.c
main.c
@@ -41,7 +41,7 @@ add_vpp_executable(vpp_api_test ENABLE_EXPORTS
##############################################################################
# vpp_json_test
##############################################################################
-add_vpp_executable(vpp_json_test ENABLE_EXPORTS
+add_vpp_executable(vpp_json_test ENABLE_EXPORTS NO_INSTALL
SOURCES json_format.c json_test.c
LINK_LIBRARIES vppinfra m
)
@@ -49,7 +49,11 @@ add_vpp_executable(vpp_json_test ENABLE_EXPORTS
##############################################################################
# vat headers
##############################################################################
-install(FILES vat.h json_format.h DESTINATION include/vat)
+install(
+ FILES vat.h json_format.h
+ DESTINATION include/vat
+ COMPONENT vpp-dev
+)
##############################################################################
# restart