aboutsummaryrefslogtreecommitdiffstats
path: root/src/vcl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/vcl/CMakeLists.txt')
-rw-r--r--src/vcl/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/vcl/CMakeLists.txt b/src/vcl/CMakeLists.txt
index 610b422d113..2f738f39d1a 100644
--- a/src/vcl/CMakeLists.txt
+++ b/src/vcl/CMakeLists.txt
@@ -11,6 +11,11 @@
# See the License for the specific language governing permissions and
# limitations under the License.
+if(NOT "${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
+ message(WARNING "-- vppcom is currently only support on Linux - disabled")
+ return()
+endif()
+
##############################################################################
# vppcom shared library
##############################################################################
@@ -50,4 +55,4 @@ add_vpp_headers(vcl
vppcom.h
vcl_locked.h
ldp_socket_wrapper.h
-) \ No newline at end of file
+)