aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt195
1 files changed, 77 insertions, 118 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index 78a2ba77c0e..fb8d294009d 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -26,6 +26,22 @@ list(APPEND VNET_SOURCES
config.c
devices/devices.c
devices/netlink.c
+ dev/api.c
+ dev/args.c
+ dev/cli.c
+ dev/config.c
+ dev/counters.c
+ dev/dev.c
+ dev/dev_api.c
+ dev/error.c
+ dev/format.c
+ dev/handlers.c
+ dev/pci.c
+ dev/port.c
+ dev/process.c
+ dev/queue.c
+ dev/runtime.c
+ error.c
flow/flow.c
flow/flow_cli.c
flow/flow_api.c
@@ -35,9 +51,12 @@ list(APPEND VNET_SOURCES
interface_cli.c
interface_format.c
interface_output.c
+ interface/caps.c
interface/rx_queue.c
interface/tx_queue.c
interface/runtime.c
+ interface/monitor.c
+ interface/stats.c
interface_stats.c
misc.c
)
@@ -50,13 +69,14 @@ list(APPEND VNET_MULTIARCH_SOURCES
list(APPEND VNET_HEADERS
api_errno.h
+ error.h
buffer.h
config.h
devices/devices.h
devices/netlink.h
+ dev/dev.h
flow/flow.h
global_funcs.h
- handoff.h
interface/rx_queue_funcs.h
interface/tx_queue_funcs.h
interface.h
@@ -79,6 +99,7 @@ list(APPEND VNET_HEADERS
)
list(APPEND VNET_API_FILES
+ dev/dev.api
interface.api
interface_types.api
ip/ip_types.api
@@ -293,30 +314,6 @@ list(APPEND VNET_HEADERS
)
##############################################################################
-# Layer 2 / vxlan
-##############################################################################
-list(APPEND VNET_SOURCES
- vxlan/vxlan.c
- vxlan/encap.c
- vxlan/decap.c
- vxlan/vxlan_api.c
-)
-
-list(APPEND VNET_MULTIARCH_SOURCES
- vxlan/encap.c
-)
-
-list(APPEND VNET_HEADERS
- vxlan/vxlan.h
- vxlan/vxlan_packet.h
- vxlan/vxlan_error.def
-)
-
-list(APPEND VNET_MULTIARCH_SOURCES vxlan/decap.c)
-
-list(APPEND VNET_API_FILES vxlan/vxlan.api)
-
-##############################################################################
# Layer 2 / Bonding
##############################################################################
list(APPEND VNET_SOURCES
@@ -440,13 +437,11 @@ list(APPEND VNET_HEADERS
ip/icmp4.h
ip/icmp6.h
ip/igmp_packet.h
- ip/ip4_error.h
ip/ip4.h
ip/ip4_mtrie.h
ip/ip4_inlines.h
ip/ip4_packet.h
ip/ip46_address.h
- ip/ip6_error.h
ip/ip6.h
ip/ip6_hop_by_hop.h
ip/ip6_hop_by_hop_packet.h
@@ -458,6 +453,7 @@ list(APPEND VNET_HEADERS
ip/ip_table.h
ip/ip_interface.h
ip/ip_packet.h
+ ip/ip_psh_cksum.h
ip/ip_source_and_port_range_check.h
ip/ip_types.h
ip/lookup.h
@@ -465,6 +461,8 @@ list(APPEND VNET_HEADERS
ip/protocols.def
ip/punt_error.def
ip/punt.h
+ ip/reass/ip4_sv_reass.h
+ ip/reass/ip6_sv_reass.h
)
list(APPEND VNET_API_FILES
@@ -665,6 +663,7 @@ list(APPEND VNET_SOURCES
udp/udp_encap.c
udp/udp_decap.c
udp/udp_api.c
+ udp/udp_output.c
)
list(APPEND VNET_MULTIARCH_SOURCES
@@ -675,6 +674,7 @@ list(APPEND VNET_MULTIARCH_SOURCES
list(APPEND VNET_HEADERS
udp/udp_error.def
udp/udp.h
+ udp/udp_encap.h
udp/udp_packet.h
udp/udp_inlines.h
udp/udp_local.h
@@ -685,27 +685,10 @@ list(APPEND VNET_API_FILES udp/udp.api)
##############################################################################
# Tunnel protocol: gre
##############################################################################
-list(APPEND VNET_SOURCES
- gre/gre.c
- gre/node.c
- gre/interface.c
- gre/pg.c
- gre/gre_api.c
-)
-
-list(APPEND VNET_MULTIARCH_SOURCES
- gre/node.c
- gre/gre.c
-)
-
list(APPEND VNET_HEADERS
- gre/gre.h
gre/packet.h
- gre/error.def
)
-list(APPEND VNET_API_FILES gre/gre.api)
-
##############################################################################
# Tunnel protocol: ipip
##############################################################################
@@ -744,6 +727,7 @@ list(APPEND VNET_API_FILES
list(APPEND VNET_HEADERS
tunnel/tunnel.h
tunnel/tunnel_dp.h
+ tunnel/tunnel_types_api.h
)
##############################################################################
@@ -770,39 +754,15 @@ list(APPEND VNET_MULTIARCH_SOURCES
list(APPEND VNET_HEADERS
mpls/mpls.h
+ mpls/mpls_lookup.h
mpls/mpls_types.h
mpls/mpls_tunnel.h
mpls/packet.h
- mpls/error.def
)
list(APPEND VNET_API_FILES mpls/mpls.api)
##############################################################################
-# Tunnel protocol: vxlan-gbp
-##############################################################################
-list(APPEND VNET_SOURCES
- vxlan-gbp/decap.c
- vxlan-gbp/encap.c
- vxlan-gbp/vxlan_gbp_api.c
- vxlan-gbp/vxlan_gbp.c
- vxlan-gbp/vxlan_gbp_packet.c
-)
-
-list (APPEND VNET_MULTIARCH_SOURCES
- vxlan-gbp/decap.c
- vxlan-gbp/encap.c
-)
-
-list(APPEND VNET_HEADERS
- vxlan-gbp/vxlan_gbp.h
- vxlan-gbp/vxlan_gbp_packet.h
- vxlan-gbp/vxlan_gbp_error.def
-)
-
-list(APPEND VNET_API_FILES vxlan-gbp/vxlan_gbp.api)
-
-##############################################################################
# Tunnel protocol: vxlan-gpe
##############################################################################
@@ -835,16 +795,21 @@ list(APPEND VNET_SOURCES
srv6/sr_policy_rewrite.c
srv6/sr_steering.c
srv6/sr_api.c
+ srv6/sr_pt.c
+ srv6/sr_pt_node.c
+ srv6/sr_pt_api.c
)
list(APPEND VNET_HEADERS
srv6/sr_packet.h
srv6/sr.h
+ srv6/sr_pt.h
)
list(APPEND VNET_API_FILES
srv6/sr.api
srv6/sr_types.api
+ srv6/sr_pt.api
)
##############################################################################
@@ -882,6 +847,21 @@ list(APPEND VNET_HEADERS
list(APPEND VNET_API_FILES ipfix-export/ipfix_export.api)
##############################################################################
+# HASH
+##############################################################################
+list(APPEND VNET_SOURCES
+ hash/hash.c
+ hash/cli.c
+ hash/crc32_5tuple.c
+ hash/handoff_eth.c
+ hash/hash_eth.c
+)
+
+list(APPEND VNET_HEADERS
+ hash/hash.h
+)
+
+##############################################################################
# GSO
##############################################################################
list(APPEND VNET_SOURCES
@@ -915,23 +895,6 @@ list(APPEND VNET_HEADERS
)
##############################################################################
-# lawful intercept
-##############################################################################
-
-list(APPEND VNET_SOURCES
- lawful-intercept/lawful_intercept.c
- lawful-intercept/node.c
-)
-
-list(APPEND VNET_MULTIARCH_SOURCES
- lawful-intercept/node.c
-)
-
-list(APPEND VNET_HEADERS
- lawful-intercept/lawful_intercept.h
-)
-
-##############################################################################
# SPAN (port mirroring)
##############################################################################
@@ -982,15 +945,11 @@ list(APPEND VNET_SOURCES
devices/virtio/format.c
devices/virtio/node.c
devices/virtio/pci.c
- devices/virtio/vhost_user.c
- devices/virtio/vhost_user_input.c
- devices/virtio/vhost_user_output.c
- devices/virtio/vhost_user_api.c
devices/virtio/virtio.c
devices/virtio/virtio_api.c
devices/virtio/virtio_pci_legacy.c
devices/virtio/virtio_pci_modern.c
- devices/virtio/virtio_process.c
+ devices/virtio/virtio_pre_input.c
devices/virtio/virtio_types_api.c
)
@@ -1002,20 +961,15 @@ list(APPEND VNET_HEADERS
devices/virtio/virtio_pci_legacy.h
devices/virtio/virtio_pci_modern.h
devices/virtio/vhost_std.h
- devices/virtio/vhost_user.h
devices/virtio/virtio_types_api.h
)
list(APPEND VNET_MULTIARCH_SOURCES
- devices/virtio/vhost_user_input.c
- devices/virtio/vhost_user_output.c
devices/virtio/node.c
- devices/af_packet/node.c
devices/virtio/device.c
)
list(APPEND VNET_API_FILES
- devices/virtio/vhost_user.api
devices/virtio/virtio.api
devices/virtio/virtio_types.api
)
@@ -1024,6 +978,7 @@ list(APPEND VNET_API_FILES
# tap interface (with virtio backend)
##############################################################################
+if("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
list(APPEND VNET_SOURCES
devices/tap/cli.c
devices/tap/tap.c
@@ -1037,6 +992,7 @@ list(APPEND VNET_HEADERS
list(APPEND VNET_API_FILES
devices/tap/tapv2.api
)
+endif()
##############################################################################
# tap interface (with virtio backend)
@@ -1064,6 +1020,7 @@ list(APPEND VNET_SOURCES
session/session_rules_table.c
session/session_lookup.c
session/session_node.c
+ session/session_input.c
session/transport.c
session/application.c
session/application_worker.c
@@ -1110,27 +1067,6 @@ list(APPEND VNET_HEADERS
tls/tls_test.h
)
-##############################################################################
-# Linux packet interface
-##############################################################################
-
-list(APPEND VNET_SOURCES
- devices/af_packet/af_packet.c
- devices/af_packet/device.c
- devices/af_packet/node.c
- devices/af_packet/cli.c
- devices/af_packet/af_packet_api.c
-)
-
-list(APPEND VNET_MULTIARCH_SOURCES
- devices/af_packet/device.c
-)
-
-list(APPEND VNET_HEADERS
- devices/af_packet/af_packet.h
-)
-
-list(APPEND VNET_API_FILES devices/af_packet/af_packet.api)
##############################################################################
# Driver feature graph arc support
@@ -1154,6 +1090,7 @@ list(APPEND VNET_API_FILES feature/feature.api)
# FIXME: unix/hgshm.c
+if("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
list(APPEND VNET_SOURCES
unix/gdb_funcs.c
unix/tuntap.c
@@ -1162,6 +1099,7 @@ list(APPEND VNET_SOURCES
list(APPEND VNET_HEADERS
unix/tuntap.h
)
+endif()
##############################################################################
# FIB
@@ -1208,7 +1146,11 @@ list(APPEND VNET_SOURCES
list(APPEND VNET_HEADERS
fib/fib.h
fib/fib_api.h
+ fib/fib_entry_track.h
fib/ip4_fib.h
+ fib/ip4_fib_8.h
+ fib/ip4_fib_16.h
+ fib/ip4_fib_hash.h
fib/ip6_fib.h
fib/fib_types.h
fib/fib_table.h
@@ -1216,6 +1158,8 @@ list(APPEND VNET_HEADERS
fib/fib_node_list.h
fib/fib_entry.h
fib/fib_entry_delegate.h
+ fib/fib_path.h
+ fib/fib_path_list.h
fib/fib_sas.h
fib/fib_source.h
)
@@ -1295,6 +1239,7 @@ list(APPEND VNET_MULTIARCH_SOURCES
list(APPEND VNET_HEADERS
dpo/load_balance.h
+ dpo/load_balance_map.h
dpo/drop_dpo.h
dpo/lookup_dpo.h
dpo/punt_dpo.h
@@ -1408,10 +1353,13 @@ list(APPEND VNET_MULTIARCH_SOURCES
)
list(APPEND VNET_HEADERS
- bier/bier_types.h
+ bier/bier_bit_string.h
bier/bier_entry.h
+ bier/bier_fwd.h
+ bier/bier_hdr_inlines.h
bier/bier_update.h
bier/bier_table.h
+ bier/bier_types.h
)
list(APPEND VNET_API_FILES bier/bier.api)
@@ -1507,6 +1455,17 @@ add_vpp_library (vatclient
DEPENDS api_headers
)
+add_vat_test_library(vnet
+ interface_test.c
+ ip/ip_test.c
+ arp/arp_test.c
+ ip6-nd/ip6_nd_test.c
+ srmpls/sr_mpls_test.c
+ session/session_test.c
+ l2/l2_test.c
+ ipsec/ipsec_test.c
+)
+
##############################################################################
# VAT2 plugins
##############################################################################