aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index 5bac7dbc196..a45f921fb08 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -491,6 +491,13 @@ list(APPEND VNET_SOURCES
ipsec/ipsec_api.c
)
+list(APPEND VNET_MULTIARCH_SOURCES
+ ipsec/esp_encrypt.c
+ ipsec/esp_decrypt.c
+ ipsec/ah_decrypt.c
+ ipsec/ah_encrypt.c
+)
+
list(APPEND VNET_API_FILES ipsec/ipsec.api)
list(APPEND VNET_SOURCES