aboutsummaryrefslogtreecommitdiffstats
path: root/src/vppinfra/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/vppinfra/CMakeLists.txt')
-rw-r--r--src/vppinfra/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/src/vppinfra/CMakeLists.txt b/src/vppinfra/CMakeLists.txt
index 64420b96676..8f9d0746b42 100644
--- a/src/vppinfra/CMakeLists.txt
+++ b/src/vppinfra/CMakeLists.txt
@@ -188,7 +188,8 @@ set(VPPINFRA_HEADERS
vector_altivec.h
vector_avx2.h
vector_avx512.h
- vector_funcs.h
+ vector/mask_compare.h
+ vector/compress.h
vector.h
vector_neon.h
vector_sse42.h
@@ -264,13 +265,13 @@ if(VPP_BUILD_VPPINFRA_TESTS)
endforeach()
set(test_files
- test_vector_funcs_compress.c
- test_vector_funcs_mask_compare.c
+ vector/test/compress.c
+ vector/test/mask_compare.c
)
add_vpp_executable(test_vector_funcs
SOURCES
- test_vector_funcs.c
+ vector/test/test.c
${test_files}
LINK_LIBRARIES vppinfra
)