aboutsummaryrefslogtreecommitdiffstats
path: root/vpp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'vpp/Makefile.am')
-rw-r--r--vpp/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/vpp/Makefile.am b/vpp/Makefile.am
index f90cb647d94..25d72749f3d 100644
--- a/vpp/Makefile.am
+++ b/vpp/Makefile.am
@@ -121,6 +121,9 @@ vpp_LDFLAGS += -Wl,--no-whole-archive
if WITH_DPDK_CRYPTO
vpp_LDADD += -L$(AESNI_MULTI_BUFFER_LIB_PATH) -lIPSec_MB
endif
+if WITH_DPDK_MLX5_PMD
+vpp_LDFLAGS += -libverbs -lmlx5 -lnuma
+endif
endif
vpp_LDADD += -lvppinfra -lm -lpthread -ldl