aboutsummaryrefslogtreecommitdiffstats
path: root/router/Makefile.am
diff options
context:
space:
mode:
authorHongjun Ni <hongjun.ni@intel.com>2018-08-07 23:40:48 +0800
committerHongjun Ni <hongjun.ni@intel.com>2018-08-21 19:04:54 +0800
commit31a24b656050878af31122b085a345cfe35e742b (patch)
treea62a43d41827d8316f22674c83a6fe0f45700371 /router/Makefile.am
parent38f03b2d6ca0a83846171a0f57b0ae3834f6c2a5 (diff)
Remove FIB_1.0 support and fix FIB_2.0 issue
Change-Id: I90e593993851a364b728034c13e8e69852b558c4 Signed-off-by: Hongjun Ni <hongjun.ni@intel.com>
Diffstat (limited to 'router/Makefile.am')
-rw-r--r--router/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/router/Makefile.am b/router/Makefile.am
index b9de6a1..a4387dd 100644
--- a/router/Makefile.am
+++ b/router/Makefile.am
@@ -3,10 +3,15 @@ AUTOMAKE_OPTIONS = foreign subdir-objects
AM_CFLAGS = -Wall -I@TOOLKIT_INCLUDE@
lib_LTLIBRARIES = router.la
-router_la_SOURCES = router/tap_inject.c \
- router/tap_inject_netlink.c \
- router/tap_inject_node.c \
- router/tap_inject_tap.c
+router_la_SOURCES = \
+ router/tap_inject.c \
+ router/tap_inject_netlink.c \
+ router/tap_inject_node.c \
+ router/tap_inject_tap.c
+
+nobase_include_HEADERS = \
+ router/tap_inject.h
+
router_la_LDFLAGS = -module
router_la_LIBADD = -lrtnl