aboutsummaryrefslogtreecommitdiffstats
path: root/router/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'router/Makefile.am')
-rw-r--r--router/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/router/Makefile.am b/router/Makefile.am
index b9de6a1..a4387dd 100644
--- a/router/Makefile.am
+++ b/router/Makefile.am
@@ -3,10 +3,15 @@ AUTOMAKE_OPTIONS = foreign subdir-objects
AM_CFLAGS = -Wall -I@TOOLKIT_INCLUDE@
lib_LTLIBRARIES = router.la
-router_la_SOURCES = router/tap_inject.c \
- router/tap_inject_netlink.c \
- router/tap_inject_node.c \
- router/tap_inject_tap.c
+router_la_SOURCES = \
+ router/tap_inject.c \
+ router/tap_inject_netlink.c \
+ router/tap_inject_node.c \
+ router/tap_inject_tap.c
+
+nobase_include_HEADERS = \
+ router/tap_inject.h
+
router_la_LDFLAGS = -module
router_la_LIBADD = -lrtnl