aboutsummaryrefslogtreecommitdiffstats
path: root/router/Makefile.am
diff options
context:
space:
mode:
authorJeff Shaw <jeffrey.b.shaw@intel.com>2016-09-21 19:12:46 -0400
committerJeff Shaw <jeffrey.b.shaw@intel.com>2016-10-04 15:58:00 -0400
commitdfae7756baf895957a43944f63bfe0c850b16467 (patch)
treecb8b0c5ae0a09835f9817a8956bd86dbf9a1de57 /router/Makefile.am
parent961580e47e58e9cb7175ec89703bc951c7ce71b2 (diff)
[router] IPv6 support and refactoring.
This change adds support for IPv6 while refactoring most of the original plugin code in the following ways. - Adhere to vpp style guidelines. - Split the netlink, node, and tap processing into separate files named with a "tap_inject" prefix which more accurately represents the functionality. - Implement our own tap management and rx/tx. This is to reduce the overhead of passing packets in and out of vnet tap devices, in favor of directly reading/writing from the tap. - Change how nodes work. Now we have neighbor, rx, and tx nodes. The neighbor node sends ARP replies and ICMP6 neighbor advertisements to the arp-input and icmp6-neighbor-solicitation nodes, respectively, before also injecting the packet to the host, making it possible for both vpp and the host network stack to resolve the next hop. The tx node injects packets into the host by writing to the tap. The rx node reads packets from the tap and sends them on its associated data plane interface. - Simplify the CLI. Instead of creating taps specifically for a given interface we create a tap for all of the Ethernet interfaces with the "enable tap-inject" CLI command. The interfaces are named with a "vpp" prefix, i.e. "vpp0". Also add a "disable tap-inject" option. - Provide ability to enable at configuration time with the tap-inject { enable } stanza. Change-Id: I6b56da606e2da1d793ce6aca222fe4eb5a4e070d Signed-off-by: Jeff Shaw <jeffrey.b.shaw@intel.com>
Diffstat (limited to 'router/Makefile.am')
-rw-r--r--router/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/router/Makefile.am b/router/Makefile.am
index 2e9b38f..b9de6a1 100644
--- a/router/Makefile.am
+++ b/router/Makefile.am
@@ -3,7 +3,10 @@ AUTOMAKE_OPTIONS = foreign subdir-objects
AM_CFLAGS = -Wall -I@TOOLKIT_INCLUDE@
lib_LTLIBRARIES = router.la
-router_la_SOURCES = router/router.c
+router_la_SOURCES = router/tap_inject.c \
+ router/tap_inject_netlink.c \
+ router/tap_inject_node.c \
+ router/tap_inject_tap.c
router_la_LDFLAGS = -module
router_la_LIBADD = -lrtnl