aboutsummaryrefslogtreecommitdiffstats
path: root/apps/http-server/CMakeLists.txt
diff options
context:
space:
mode:
authorAngelo Mantellini <manangel@cisco.com>2019-05-14 16:05:53 +0200
committerAngelo Mantellini <manangel@cisco.com>2019-05-16 13:48:23 +0200
commit5c9b2cd16e76b7d731bd31422b4a555dbeff1541 (patch)
tree1ab57c1e0eb10374879803ef9aee36724ad875ef /apps/http-server/CMakeLists.txt
parent8a4273ffe83b46bc018da58135427d40012282b8 (diff)
[HICN-195] Generate static libs for android
Change-Id: Ib78e0ba5108713c6fac0e422eb7bb6f7ba10abc7 Signed-off-by: Angelo Mantellini <manangel@cisco.com>
Diffstat (limited to 'apps/http-server/CMakeLists.txt')
-rw-r--r--apps/http-server/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/apps/http-server/CMakeLists.txt b/apps/http-server/CMakeLists.txt
index bedb6afc1..65dcc9a98 100644
--- a/apps/http-server/CMakeLists.txt
+++ b/apps/http-server/CMakeLists.txt
@@ -62,6 +62,7 @@ include_directories(
http-client
)
+
set(LIBHTTP_SERVER hicnhttpserver)
build_library(${LIBHTTP_SERVER}
@@ -75,7 +76,7 @@ build_library(${LIBHTTP_SERVER}
build_executable(${HTTP_SERVER}
SOURCES ${APP_SOURCE_FILES}
- LINK_LIBRARIES ${LIBHTTP_SERVER} ${WSOCK32_LIBRARY} ${WS2_32_LIBRARY}
+ LINK_LIBRARIES ${LIBHTTP_SERVER} ${LIBRARIES} ${ZLIB_LIBRARIES} ${WSOCK32_LIBRARY} ${WS2_32_LIBRARY}
DEPENDS ${LIBHTTP_SERVER}
COMPONENT ${HICN_APPS}
DEFINITIONS ${COMPILER_DEFINITIONS}