aboutsummaryrefslogtreecommitdiffstats
path: root/apps/http-server/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'apps/http-server/CMakeLists.txt')
-rw-r--r--apps/http-server/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/apps/http-server/CMakeLists.txt b/apps/http-server/CMakeLists.txt
index bedb6afc1..65dcc9a98 100644
--- a/apps/http-server/CMakeLists.txt
+++ b/apps/http-server/CMakeLists.txt
@@ -62,6 +62,7 @@ include_directories(
http-client
)
+
set(LIBHTTP_SERVER hicnhttpserver)
build_library(${LIBHTTP_SERVER}
@@ -75,7 +76,7 @@ build_library(${LIBHTTP_SERVER}
build_executable(${HTTP_SERVER}
SOURCES ${APP_SOURCE_FILES}
- LINK_LIBRARIES ${LIBHTTP_SERVER} ${WSOCK32_LIBRARY} ${WS2_32_LIBRARY}
+ LINK_LIBRARIES ${LIBHTTP_SERVER} ${LIBRARIES} ${ZLIB_LIBRARIES} ${WSOCK32_LIBRARY} ${WS2_32_LIBRARY}
DEPENDS ${LIBHTTP_SERVER}
COMPONENT ${HICN_APPS}
DEFINITIONS ${COMPILER_DEFINITIONS}