aboutsummaryrefslogtreecommitdiffstats
path: root/extras/packethicn/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2021-04-09 11:26:52 +0000
committerGerrit Code Review <gerrit@fd.io>2021-04-09 11:26:52 +0000
commit3e541d7c947cc2f9db145f26c9274efd29a6fb56 (patch)
tree9c30e010d8dda73f5e0455cd8cd3380982ef6589 /extras/packethicn/CMakeLists.txt
parentd6a155b63c37682a25b1f5a02c0189af5dd3edef (diff)
parentcd0aa7de71b4f514879b8fc40c57665bbf93c0cd (diff)
Merge "[HICN-696] packethicn: add support for native hicn and fix find wireshark for macOS"transport-ng
Diffstat (limited to 'extras/packethicn/CMakeLists.txt')
-rw-r--r--extras/packethicn/CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/extras/packethicn/CMakeLists.txt b/extras/packethicn/CMakeLists.txt
index f8be36eff..cb168ae1f 100644
--- a/extras/packethicn/CMakeLists.txt
+++ b/extras/packethicn/CMakeLists.txt
@@ -24,7 +24,13 @@ set(CMAKE_MODULE_PATH
set(PACKETHICN packethicn)
-find_package(Wireshark CONFIG REQUIRED)
+if(APPLE)
+ find_package(Wireshark CONFIG REQUIRED
+ PATHS /usr/local/opt/wireshark/lib/wireshark/cmake/ /usr/local/Cellar/wireshark/*/lib/wireshark/cmake
+ )
+else()
+ find_package(Wireshark CONFIG REQUIRED)
+endif()
MATH(EXPR Wireshark_PATCH_NEXT_VERSION "${Wireshark_PATCH_VERSION}+1")
set(Wireshark_NEXT_VERSION ${Wireshark_MAJOR_VERSION}.${Wireshark_MINOR_VERSION}.${Wireshark_PATCH_NEXT_VERSION})
@@ -32,8 +38,8 @@ set(Wireshark_NEXT_VERSION ${Wireshark_MAJOR_VERSION}.${Wireshark_MINOR_VERSION}
if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
find_package(Libhicn REQUIRED)
else()
- if (DISABLE_SHARED_LIBRARIES)
- if (WIN32)
+ if(DISABLE_SHARED_LIBRARIES)
+ if(WIN32)
set(HICN_LIBRARIES ${LIBHICN_STATIC})
else()
set(HICN_LIBRARIES ${LIBHICN_STATIC} log)