aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-plugin/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2022-09-26 10:23:04 +0200
committerMauro Sardara <msardara@cisco.com>2022-09-26 08:31:57 +0000
commitdb6aae6b57caca6414287e737885f4c39d314afd (patch)
tree275a4438858817f3f8a7e9754c695a5a5a3a8525 /hicn-plugin/src/CMakeLists.txt
parentadbdfdf7489e1909f29e2dd02edb7d15c258ed19 (diff)
chore(hicn-plugin): install hicn.api.json
The hicn.api.json is currently used by govpp/vapi_c_gen/vapi_cpp_gen etc. to generate the APIs to configure the hicn plugin. It should be installed in the system as external component may require it to generate the api, as in the govpp case (cf https://github.com/FDio/govpp/tree/master/binapi). The hicn.api.son file will be installed with the rest of the plugins API (share/vpp/api/plugins) Ticket: HICN-797 Signed-off-by: Mauro Sardara <msardara@cisco.com> Change-Id: Ief7f0010a718efd272e260552f2f2d1428fac486
Diffstat (limited to 'hicn-plugin/src/CMakeLists.txt')
-rw-r--r--hicn-plugin/src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/hicn-plugin/src/CMakeLists.txt b/hicn-plugin/src/CMakeLists.txt
index e05ba1fec..0ba683b11 100644
--- a/hicn-plugin/src/CMakeLists.txt
+++ b/hicn-plugin/src/CMakeLists.txt
@@ -199,6 +199,11 @@ execute_process(
COMMAND ${VPP_HOME}/bin/vapi_c_gen.py ${PROJECT_BINARY_DIR}/vapi/hicn.api.json
COMMAND ${VPP_HOME}/bin/vapi_cpp_gen.py ${PROJECT_BINARY_DIR}/vapi/hicn.api.json
)
+install(
+ FILES ${PROJECT_BINARY_DIR}/vapi/hicn.api.json
+ DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/vpp/api/plugins
+ COMPONENT ${HICN_PLUGIN}
+)
##############################################################