aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-plugin/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'hicn-plugin/src/CMakeLists.txt')
-rw-r--r--hicn-plugin/src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/hicn-plugin/src/CMakeLists.txt b/hicn-plugin/src/CMakeLists.txt
index e05ba1fec..0ba683b11 100644
--- a/hicn-plugin/src/CMakeLists.txt
+++ b/hicn-plugin/src/CMakeLists.txt
@@ -199,6 +199,11 @@ execute_process(
COMMAND ${VPP_HOME}/bin/vapi_c_gen.py ${PROJECT_BINARY_DIR}/vapi/hicn.api.json
COMMAND ${VPP_HOME}/bin/vapi_cpp_gen.py ${PROJECT_BINARY_DIR}/vapi/hicn.api.json
)
+install(
+ FILES ${PROJECT_BINARY_DIR}/vapi/hicn.api.json
+ DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/vpp/api/plugins
+ COMPONENT ${HICN_PLUGIN}
+)
##############################################################