aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/perfmon/CMakeLists.txt
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2018-10-24 15:54:52 -0400
committerFlorin Coras <florin.coras@gmail.com>2018-10-25 01:04:44 +0000
commit5f1fd46573aa111018f838db14de53e8ecf854b3 (patch)
tree28b5dd0c89a98466b80fd905d221c2c333d0d962 /src/plugins/perfmon/CMakeLists.txt
parent380c1676e25e8df3e5449247e3d6f8414bdae509 (diff)
Add x86_64 perfmon tables
The license issue is resolved, so we can package the .json files. Added to the vpp-dev package in .tar.xz form, which saves a lot of space. Updated the perfmon error log entry: tell folks where to find the compressed tarball, and how to extract it. Change-Id: I3ed351fbf154cc3ba22d5f9c666acff77a2a14cf Signed-off-by: Dave Barach <dave@barachs.net>
Diffstat (limited to 'src/plugins/perfmon/CMakeLists.txt')
-rw-r--r--src/plugins/perfmon/CMakeLists.txt23
1 files changed, 5 insertions, 18 deletions
diff --git a/src/plugins/perfmon/CMakeLists.txt b/src/plugins/perfmon/CMakeLists.txt
index 30e1f2caf3e..845dd3cc6c8 100644
--- a/src/plugins/perfmon/CMakeLists.txt
+++ b/src/plugins/perfmon/CMakeLists.txt
@@ -18,21 +18,8 @@ add_vpp_plugin(perfmon
parse_util.c
)
-# Reenable / extend when .json file license issue fixed
-#
-# set (PERFMON_JSON_FILES
-# haswell_core_v28.json
-# haswellx_core_v20.json
-# ivybridge_core_v21.json
-# ivytown_core_v20.json
-# jaketown_core_v20.json
-# sandybridge_core_v16.json
-# skylake_core_v42.json
-# skylakex_core_v1.12.json
-# )
-
-# install(
-# FILES ${PERFMON_JSON_FILES}
-# DESTINATION share/vpp/plugins/perfmon
-# COMPONENT vpp-dev
-# )
+install(
+ FILES PerfmonTables.tar.xz
+ DESTINATION share/vpp/plugins/perfmon
+ COMPONENT vpp-dev
+)