aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/tlsopenssl/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorin Coras <fcoras@cisco.com>2020-12-16 17:05:56 -0800
committerDave Barach <openvpp@barachs.net>2020-12-18 22:28:03 +0000
commit5b8b1aec213baf65d3051c849f5f3deff37d06b5 (patch)
treecfdcaa17dad3c48b27c8e358fbb4b6b53e3e9523 /src/plugins/tlsopenssl/CMakeLists.txt
parent8b60fb0fe6e29aac1847c0b381c0f84165b27b61 (diff)
tls: add custom openssl bio
The bio interacts directly with the session so it avoids using an intermediary mem bio and, implicitly, higher memory consumption and an extra memcpy. Type: improvement Signed-off-by: Florin Coras <fcoras@cisco.com> Change-Id: Ifb675cfd12df86396a7a738a6cd4d0882c69ad2f
Diffstat (limited to 'src/plugins/tlsopenssl/CMakeLists.txt')
-rw-r--r--src/plugins/tlsopenssl/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/plugins/tlsopenssl/CMakeLists.txt b/src/plugins/tlsopenssl/CMakeLists.txt
index 8ac36cfe3fd..61d3638a39a 100644
--- a/src/plugins/tlsopenssl/CMakeLists.txt
+++ b/src/plugins/tlsopenssl/CMakeLists.txt
@@ -12,10 +12,11 @@
# limitations under the License.
include (CheckFunctionExists)
-if(OPENSSL_FOUND)
+if(OPENSSL_FOUND AND OPENSSL_VERSION VERSION_GREATER_EQUAL "1.1.0")
include_directories(${OPENSSL_INCLUDE_DIR})
add_vpp_plugin(tlsopenssl
SOURCES
+ tls_bio.c
tls_openssl.c
tls_openssl_api.c
tls_async.c