aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/tlsopenssl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/tlsopenssl/CMakeLists.txt')
-rw-r--r--src/plugins/tlsopenssl/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/plugins/tlsopenssl/CMakeLists.txt b/src/plugins/tlsopenssl/CMakeLists.txt
index 8ac36cfe3fd..61d3638a39a 100644
--- a/src/plugins/tlsopenssl/CMakeLists.txt
+++ b/src/plugins/tlsopenssl/CMakeLists.txt
@@ -12,10 +12,11 @@
# limitations under the License.
include (CheckFunctionExists)
-if(OPENSSL_FOUND)
+if(OPENSSL_FOUND AND OPENSSL_VERSION VERSION_GREATER_EQUAL "1.1.0")
include_directories(${OPENSSL_INCLUDE_DIR})
add_vpp_plugin(tlsopenssl
SOURCES
+ tls_bio.c
tls_openssl.c
tls_openssl_api.c
tls_async.c