aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/vrrp/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Smith <mgsmith@netgate.com>2020-02-11 11:25:32 -0600
committerDave Barach <openvpp@barachs.net>2020-02-13 19:46:30 +0000
commit39e9428b90bc74d1bb15fc17759c8ef6ad712418 (patch)
treede9317a906a7df43bf2140a654d3b7675cab8d86 /src/plugins/vrrp/CMakeLists.txt
parentf75defa7676759fa81ae75e7edd492572c6b8fd6 (diff)
vrrp: add plugin providing vrrp support
Type: feature Add a new plugin to support HA using VRRPv3 (RFC 5798). Change-Id: Iaa2c37e6172f8f41e9165f178f44d481f6e247b9 Signed-off-by: Matthew Smith <mgsmith@netgate.com>
Diffstat (limited to 'src/plugins/vrrp/CMakeLists.txt')
-rw-r--r--src/plugins/vrrp/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/plugins/vrrp/CMakeLists.txt b/src/plugins/vrrp/CMakeLists.txt
new file mode 100644
index 00000000000..21715d2d954
--- /dev/null
+++ b/src/plugins/vrrp/CMakeLists.txt
@@ -0,0 +1,28 @@
+#
+# Copyright 2019-2020 Rubicon Communications, LLC (Netgate)
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+
+add_vpp_plugin(vrrp
+ SOURCES
+ vrrp.c
+ vrrp_api.c
+ vrrp_cli.c
+ vrrp_format.c
+ node.c
+ vrrp_packet.c
+ vrrp_periodic.c
+
+ MULTIARCH_SOURCES
+ node.c
+
+ API_FILES
+ vrrp.api
+
+ INSTALL_HEADERS
+ vrrp.h
+
+ API_TEST_SOURCES
+ vrrp_test.c
+)