aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/vrrp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/vrrp/CMakeLists.txt')
-rw-r--r--src/plugins/vrrp/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/plugins/vrrp/CMakeLists.txt b/src/plugins/vrrp/CMakeLists.txt
new file mode 100644
index 00000000000..21715d2d954
--- /dev/null
+++ b/src/plugins/vrrp/CMakeLists.txt
@@ -0,0 +1,28 @@
+#
+# Copyright 2019-2020 Rubicon Communications, LLC (Netgate)
+#
+# SPDX-License-Identifier: Apache-2.0
+#
+
+add_vpp_plugin(vrrp
+ SOURCES
+ vrrp.c
+ vrrp_api.c
+ vrrp_cli.c
+ vrrp_format.c
+ node.c
+ vrrp_packet.c
+ vrrp_periodic.c
+
+ MULTIARCH_SOURCES
+ node.c
+
+ API_FILES
+ vrrp.api
+
+ INSTALL_HEADERS
+ vrrp.h
+
+ API_TEST_SOURCES
+ vrrp_test.c
+)