aboutsummaryrefslogtreecommitdiffstats
path: root/src/vlibapi/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2022-05-20 13:05:38 +0200
committerOle Tr�an <otroan@employees.org>2022-09-26 08:12:57 +0000
commitb70497124840fb6d9e8e5cf7239a41cb2bc7013c (patch)
tree090c957135d3e99db69d74ef5091bab8aaa21490 /src/vlibapi/CMakeLists.txt
parent617d429d2e38ac0cdb107dbfd86301b36d9f8e31 (diff)
api: keep api common code in vlibapi
Type: refactor Change-Id: I6edbff9a02fcb3c592ccfe8f47ddb3f848be1b6d Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'src/vlibapi/CMakeLists.txt')
-rw-r--r--src/vlibapi/CMakeLists.txt20
1 files changed, 11 insertions, 9 deletions
diff --git a/src/vlibapi/CMakeLists.txt b/src/vlibapi/CMakeLists.txt
index e6937a6db01..95bb4cf7469 100644
--- a/src/vlibapi/CMakeLists.txt
+++ b/src/vlibapi/CMakeLists.txt
@@ -11,16 +11,18 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-install(
- FILES
- api_helper_macros.h
+add_vpp_library (vlibapi
+ SOURCES
+ api_shared.c
+ node_serialize.c
+ memory_shared.c
+
+ INSTALL_HEADERS
api.h
- vat_helper_macros.h
api_common.h
+ api_helper_macros.h
api_types.h
-
- DESTINATION
- ${CMAKE_INSTALL_INCLUDEDIR}/vlibapi
-
- COMPONENT vpp-dev
+ vat_helper_macros.h
+ memory_shared.h
)
+