aboutsummaryrefslogtreecommitdiffstats
path: root/src/vlibapi/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/vlibapi/CMakeLists.txt')
-rw-r--r--src/vlibapi/CMakeLists.txt20
1 files changed, 11 insertions, 9 deletions
diff --git a/src/vlibapi/CMakeLists.txt b/src/vlibapi/CMakeLists.txt
index e6937a6db01..95bb4cf7469 100644
--- a/src/vlibapi/CMakeLists.txt
+++ b/src/vlibapi/CMakeLists.txt
@@ -11,16 +11,18 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-install(
- FILES
- api_helper_macros.h
+add_vpp_library (vlibapi
+ SOURCES
+ api_shared.c
+ node_serialize.c
+ memory_shared.c
+
+ INSTALL_HEADERS
api.h
- vat_helper_macros.h
api_common.h
+ api_helper_macros.h
api_types.h
-
- DESTINATION
- ${CMAKE_INSTALL_INCLUDEDIR}/vlibapi
-
- COMPONENT vpp-dev
+ vat_helper_macros.h
+ memory_shared.h
)
+