aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorNathan Skrzypczak <nathan.skrzypczak@gmail.com>2020-08-31 15:33:57 +0200
committerNathan Skrzypczak <nathan.skrzypczak@gmail.com>2020-09-03 16:49:19 +0200
commit0c936b147f4fc52bdb685f701bc7d93959a1a6a2 (patch)
tree6a61a3e57a457ad96792b8215e3d31c1ffc5aa9e /src/vnet/CMakeLists.txt
parent2284817eae67d78f3a9afffed9d830da658dd568 (diff)
crypto: Add async crypto APIs
Type: feature This adds api calls for the following CLIs: * set sw_scheuduler worker <N> crypto on|off * set crypto async dispatch polling|interrupt * set crypto handler * set crypto async handler Change-Id: Ic701d149c440e42ea4575da42b9f69e4c8759602 Signed-off-by: Nathan Skrzypczak <nathan.skrzypczak@gmail.com>
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index 737a17e078a..7acc40087fc 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -568,6 +568,7 @@ list(APPEND VNET_SOURCES
crypto/crypto.c
crypto/format.c
crypto/node.c
+ crypto/crypto_api.c
)
list(APPEND VNET_HEADERS
@@ -576,6 +577,8 @@ list(APPEND VNET_HEADERS
list(APPEND VNET_MULTIARCH_SOURCES crypto/node.c)
+list(APPEND VNET_API_FILES crypto/crypto.api)
+
##############################################################################
# Layer 3 protocol: IPSec
##############################################################################