aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index 737a17e078a..7acc40087fc 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -568,6 +568,7 @@ list(APPEND VNET_SOURCES
crypto/crypto.c
crypto/format.c
crypto/node.c
+ crypto/crypto_api.c
)
list(APPEND VNET_HEADERS
@@ -576,6 +577,8 @@ list(APPEND VNET_HEADERS
list(APPEND VNET_MULTIARCH_SOURCES crypto/node.c)
+list(APPEND VNET_API_FILES crypto/crypto.api)
+
##############################################################################
# Layer 3 protocol: IPSec
##############################################################################