aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <neale@graphiant.com>2021-08-10 14:37:11 +0000
committerOle Tr�an <otroan@employees.org>2021-08-11 08:48:42 +0000
commita70b015ceeee158eac0d9b33d12c596e1af409b3 (patch)
treee201f192ee991198f7a202eb8eafcc1159c1f29a /src/vnet/CMakeLists.txt
parentd6953332db225d5355f50348ef3b09f0525d5282 (diff)
fib: Compiile time option to use 8-8-8-8 stride tries for FIB rather
than 16-8-8-8 Type: feature the memory trade-off is: for 8-8-8-8 tries DBGvpp# sh ip fib mtrie mem ipv4-VRF:0 mtrie:8068 hash:3499 totals: mtrie:8068 hash:3499 all:11567 for 16-8-8 DBGvpp# sh ip fib mtrie mem ipv4-VRF:0 mtrie:333056 hash:3499 totals: mtrie:333056 hash:3499 all:336555 Signed-off-by: Neale Ranns <neale@graphiant.com> Change-Id: I5271a4322d786de6e47613cff9bd432762dbed2a
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index df23738013d..66a4abc3a41 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -16,6 +16,8 @@ unset(VNET_HEADERS)
unset(VNET_API_FILES)
unset(VNET_MULTIARCH_SOURCES)
+option(VPP_IP_FIB_MTRIE_16 "IP FIB's MTRIE Stride is 16-8-8 (if not set it's 8-8-8-8)" ON)
+
##############################################################################
# Generic stuff
##############################################################################