aboutsummaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
authorPavel Kotucek <pkotucek@cisco.com>2016-12-20 10:01:20 +0100
committerDamjan Marion <dmarion.lists@gmail.com>2016-12-21 22:47:32 +0000
commitc4d1cf76072b54f630b0263cd86e01df82249568 (patch)
tree212bd23d4b7464669a407eb8711e187ca5c3171c /vnet/Makefile.am
parent1099b0db45a7a0bb597c4deb5b9387f5b6ae280f (diff)
API refactoring : l2tp
Change-Id: I30d2785ceaf304b245192f9bce60e37e9da69023 Signed-off-by: Pavel Kotucek <pkotucek@cisco.com>
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index 4425171b9fb..37798c9c3bb 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -30,6 +30,8 @@ BUILT_SOURCES = \
vnet/ip/ip.api.json \
vnet/l2/l2.api.h \
vnet/l2/l2.api.json \
+ vnet/l2tp/l2tp.api.h \
+ vnet/l2tp/l2tp.api.json \
vnet/map/map.api.h \
vnet/map/map.api.json \
vnet/span/span.api.h \
@@ -487,11 +489,13 @@ libvnet_la_SOURCES += \
vnet/l2tp/l2tp.c \
vnet/l2tp/encap.c \
vnet/l2tp/decap.c \
- vnet/l2tp/pg.c
+ vnet/l2tp/pg.c \
+ vnet/l2tp/l2tp_api.c
nobase_include_HEADERS += \
vnet/l2tp/l2tp.h \
- vnet/l2tp/packet.h
+ vnet/l2tp/packet.h \
+ vnet/l2tp/l2tp.api.h
########################################
# Tunnel protocol: gre+mpls
@@ -964,12 +968,13 @@ api_DATA = \
vnet/interface.api.json \
vnet/ip/ip.api.json \
vnet/l2/l2.api.json \
+ vnet/l2tp/l2tp.api.json \
vnet/map/map.api.json \
vnet/span/span.api.json \
vnet/unix/tap.api.json \
vnet/vxlan/vxlan.api.json \
vnet/vxlan-gpe/vxlan_gpe.api.json
-
+
# The actual %.api.h rule is in .../build-data/packages/suffix-rules.mk
# and requires a symbolic link at the top of the vnet source tree